Unusable service, support needed

I’ve had Viasat for about 2 years. It is expensive and frustrating most of the time but I would say has generally been “good enough”. However, it has been exceptionally bad the past 2 weeks or so. As recently as yesterday, I updated my plan to the Unleashed plan as I typically run out of data by the end of the billing cycle. I read on here that I should get a TP-Link router so I ordered one and installed it today. I additionally read that I should use the Viasat browser so I downloaded it and tried using it. None of these things have worked. I need someone to figure out what is going on and provide a solution to fix it.

Hi @isitfr26 ,

I’m sorry about your experience.

Speed Check isn’t functioning for all clients at the moment, so if you want to check your speeds you can use fast.com while our tool is being fixed.

It seems like your antenna is mispointed, that probably has affected your internet experience.

You might want to consider attempting a self-repoint. You can find information about self-repoints here: Can I repoint my Viasat antenna on my own?

If a self-repoint doesn’t sound viable, then we can look into scheduling a technician visit to repoint your antenna and improve your experience.


Hi Isabela! Thanks for the feedback, can you please schedule a tech to come?

Hi @isitfr26 ,

I have contacted our Field Operations Team, you can expect a call from them to schedule the appointment.

Best regards,

Hi Isabela! I am getting a new phone on Monday that will have a new number. I will update the number on my Viasat account once I have it. For now, please have them email me to schedule the appointment.

Hi @isitfr26

We’ve left a note on the service call so that the Field Operations team will know to contact you using the email address instead of phone :slight_smile:

1 Like