Wifi no longer works

I changed plans from 12mbps/60 gig to 25mbps/60 gig. Tech came out this afternoon and installed a new modem, which would not connect properly (kept taking me to the install screen). Tech came back and reinstalled the old modem, with new software. That worked fine while he was here. Right after he left, the modem rebooted itself, and now there is no Wi-Fi signal… it doesn’t appear as an option on my phone. Modem light is solid blue (Surfbeam Gateway 2+). Have rebooted several times, reset with a pen (at the tech’s suggestion) and rebooted my phone a couple times, but nothing has worked. What’s the next step?

Hi, @Modem1,

Thanks for your message. I’ll check that now, and once I have some feedback I’ll let you know here.

Ok, I see what’s happening. Your modem is in bridge mode, and since the external router is disconnected you won’t see any Wi-Fi available.

Did you try connecting the external router again after you reboot the modem?

@Modem1, when you have a chance, please try following these instructions to set up your external router: Quick Tips Guide: VS-1 Enhanced WiFi Installation(US) » Viasat eGuide

If that does not work, please let us know.

I was able to speak with tech support this morning, and it turns out the problem is that the technician did not install a separate router! I guess he didn’t know he needed to. I set up an old Belkin Wi-Fi router I had laying around, and the internet is now working. The tech is supposed to come back Monday to provide a new router.

Thanks for looking into it. Out of curiosity, why can’t the internal wifi router in the Gateway 2+ be used with this new service plan?

Hello @Modem1

Apologies, it’s possible that he wasn’t aware of your add-on “Enhanced Wi-Fi”, which needs an ARIA Router. Good to know that he’ll be coming back with the proper equipment!

Your modem is only able to push the Wi-Fi signal up to a certain speed limit, which can well accommodate the lower speed plans.

For customers who chose to increase their plan speeds, an ARIA router was sent so that your Wi-Fi network could function with the maximum speeds our customers are paying for. This is the equipment needed for the add-on “Enhanced Wifi”.

If you don’t need your Wi-Fi at maximum speed, you won’t encounter any issues, but should you want to have a faster Wi-Fi signal, you can re-install the ARIA router.

As soon as you connect it, the modem goes into bridge mode automatically.

If you signed up for the add-on but haven’t had the time to read more about it, I recommend this FAQ guide:

What is the ARIA2210 router?

OK, that makes sense. Hopefully the tech has an ARIA when he shows up Monday, but if not at least I now know what I need.

I told him it was a speed upgrade when he showed up Friday (12mbps to 25mbps) but I guess that didn’t register.

Thanks for all the help. This forum is way better than calling customer service!

The tech came back today and said he has never seen or heard of the ARIA router before. He actually took a photo of it pulled up on my phone so he could send it to his boss. Is this a new product he might not be familiar with? Can Viasat send me one? I’d like to get my tenants back to some decent speeds…

Hi, @Modem1,

I see, sorry for the confusion. Indeed that’s a new product, so that might explain why the technician was unfamiliar with it. We’re in contact with the responsible team to understand why you did not receive the router.

However, the speeds should not be affected by that. I understand that you have a router plugged in now, right? Please run a speed test on this website: Viasat Speed Check | Home

I tested your modem speeds and they looked fine. If your current router is not good, we can disable the bridge mode, so you can try using the SB2+ internal router.

I don’t live at the property (it’s a rental) so it may be a while before I can run a speed test. The tenants complained that speeds were not good yesterday, but that could be due to the weather, and/or the router I installed. It’s a very old and inexpensive Belkin I had laying around my house, and I suspect it may be a choke point, especially because they are running multiple devices and connecting through walls/floors.

I think things will be sorted out once the correct ARIA router is installed, so any help you all can provide in that direction is appreciated.


1 Like

If you prefer, we can remove the configuration that requires your modem to use an external router. And then you will be able to connect directly to the Viasat modem’s built-in Wi-Fi (just like you did in the past).

Do you think that works?

I’d rather have the ARIA external router that was supposed to have been provided, both for the improved wifi strength and its ability to handle maximum speed. The tenants do a lot of video calls conferencing and need every bit of speed we can get.

Hi @Modem1,

We will send a request to have an Aria router shipped to you. Once we have more details we will provide an update.

Finally, we are investigating why your modem went into “bridge mode”, and just to confirm: you didn’t change the configuration, did you? :thinking: This mode kicks in once an Aria is plugged in, or when someone (agent or customer) makes the change manually.



I did not change any configurations on the modem. The tech updated or changed the modem software, and everything worked for about ten minutes (wifi included), but after he left the modem rebooted itself and that’s when the wifi stopped working.

Hi @Modem1,

Thank you for your reply.
The dedicated team is investigating the possible reasons for this to have happened.

We’ll keep you updated!

Thank you,

Hi, we have not received the ARIA router yet… just checking in to see if it’s been shipped. Thank you.

Hi, @Modem1,

I’m checking the status of that now.

Hi, @Modem1,

The service call is created and the field team is instructed to contact you, they’ll probably do it today or tomorrow.

We can not directly dispatch the router to your house, that’s why a new service order was created. As usual, the field team will provide more details when they contact you.

Thanks for your patience and cooperation so far

The tech came and installed the router yesterday. All working well so far. Thanks again to everyone here for their assistance!

Hi @Modem1 ,

We’re glad everything is working well now! If you face any other issues, don’t hesitate to let us know and we’ll be more than happy to help!