Slow Since Upgrade

My speed is horrible since you sent me the update after the new installation of the bridge.
I could barely login here to report the issue.
Please fix it and I think you should reimburse your customers some money for making us pay a large amount for not even half the speed we are paying for.
I’m paying for 75 Mbps and I’m only at 26. It’s constant, nothing has changed other than you pushing an update on the new bridge install. My speed was fantastic when the bridge was first installed, then you pushed the update and I’m not even getting the speeds of the old system.

Hi @gooby131,

I’m really sorry to hear about this bad experience you’ve had with the Viasat service.

I ran a speed test from your modem and I see good speed results:

Could you run a speed test for me using our platform? You can follow this tutorial: How to run a speed test from my modem?.

Please use the Viasat Browser and log in using your MyViasat credentials.

You can let me know whenever you run those tests so I can take a look.

Thank you,

Hi, @gooby131,

We need to see the speeds from the modem too.

When you have a chance, please send us the results from a modem speed test, as follows:
1 - Open the Viasat browserthis test won’t work on other browsers;
2 - Go to this website: Viasat Speed Check | Home
3 - Log in using your My Viasat account
4 - Run the test (wait for both tests - modem and device - to complete)
5 - Download the results (or take a screenshot)
6 - Send us the results

Thanks for your cooperation!

It won’t ever run the modem test. I’ve done it several times as I’ve been logged in.

Thank you,
Markie Cresswell

Hi, @gooby131,

Sorry for taking some time to reply.

Could you try checking your speeds with an Ethernet cable? It does seem to be something with the router. If that’s the case, it’s fixable.

I’ll also request the team to take a look at your equipment remotely.

Hi, @gooby131,

Did the speeds improve? I’ve been running some tests and looks like they’re normal now, could you confirm?

Also, you mentioned the speeds went bad after an update. Were you referring to the last technician visit? I saw in the notes they gave you a new router, is that correct?

So, now the Viasat modem is in bridge mode and you’re using the Wi-Fi signal from that new router, right?

Not quite, when the tech left everything was working very well. Speed was really fast as well as the upload. Then about a day or two later Viasat sent a remote provision on the 18th of august I believe. Ever since that update it has been really slow, even things that used to play with no problem are slow and buffer all the time. (Facebook, webpages opening etc.)

I am working on getting a test for you with the Ethernet cable. I’ll report back momentarily.

Thank you,
Markie Cresswell

Okay! So when plugged directly into the ethernet it is fantastic!!! However, when I run it through wi-fi it’s horrible!
Is it the bridge then having issues? The tech instructed we should run wi-fi through the bridge now instead of the original modem, is that correct?

with ethernet:

Hi, @gooby131,

Theoretically, setting the modem to bridge mode and broadcasting the Wi-Fi from the new router is ok.

I’ve seen before a customer who had issues with our speed check app when he had the modem in bridge mode.

When you have a chance, could you try testing the Wi-Fi from other apps, like and

I’ll verify that update you mentioned.

Another thing you could try is to set the modem out of bridge mode, and then try to connect again to your new router.

Hey, just checking in to see what you think. The speed is still pretty low.

Thank you,
Markie Cresswell

Thank you,
Markie Cresswell

Hi, @gooby131,

Before the installation of the new router, did you have any such issues?

We can try unplugging the new router and see how it works.

Here are the steps:

  • Disconnect the Aria Router;
  • Reboot your SB2+ modem (remove power for a minute and then turn it on again)
  • Connect to the SB2+ Wi-Fi signal

Test the speeds and let me know.

If the Wi-Fi does not appear, let me know so I can force the modem into “router” mode.