Return Data Saver

Please return Data Saver. We’re using more Data streaming on Peacock with 60 gigs of data than we were with 40 gigs using the Data Saver.

Hi, @msadkins1998,

We are currently running the new data saver experiment. In order to participate and have access to the new data saver you need to follow the instructions given in this topic: Announcing the Data Saver Feature Experiment!

Basically, you need to fill up this form and then let us know so we can activate the feature for you.

Please let me know if you have any doubts.

I filled out the form as you requested. How will I know when it is activated?

Thank you.

Hi, @msadkins1998,

The feature is now activated for you!

I set it to 2.6 Mbps. You can run a speed test on and check if that’s the speed you have now.

If you find any issues (e.g.: buffering, etc), please let us know. We can adjust the speeds up to 4.5Mbps if necessary.

If you use Amazon Prime, you’ll still have to adjust the video quality manually (we have been working on that, so that won’t be necessary in the future). To adjust the Prime video quality, please follow the instructions given in this video: How To Adjust Streaming Quality On Amazon Prime Video - YouTube

Thank you for activating the Data Saver experiment.

I ran the speed test and it was 2.4 bps.

1 Like

Got it, @msadkins1998,

That means everything should be working now. performs speed tests with a video file, that’s why it’s possible to see the data saver feature in action

Hi, Anderson.

We watched about 2 hours of Peacock streaming Yellowstone Sunday, yesterday, and used a lot less data than before you activated the data saver experiment for us. It seems to have improved data usage immensely. We had 2 very brief buffering instances at the beginning of the first five to ten minutes of streaming. After that we had no more buffering.

Thank you for your support. I hope I have given you enough information to help you.

Mike Adkins

1 Like

Hi, @msadkins1998,

Somehow I just saw your comment now, sorry.

Thanks for the feedback! If you have any issues let us know!

You can post any topic related to the data saver using the Data Saver Experiment category.

Hi, Anderson. I have had an issue getting on the Internet with my desktop. I use the Viasat browser. I get a message that says we have no Internet, but we do. We have to keep trying to access a website until it pops up. I’m thinking maybe the speed is a little too slow is why we are getting this. Please let me know what you think and if it’s possible to up our speed.


Hi, @msadkins1998,

Thanks for your message.

I need some information:

  • Does that issue affect just that device?
  • Does that happen on other browsers too?
  • Are you using a VPN?

Also - so I can have a better idea of the issue - when you have a chance, please send us a speed test from your modem, as follows:

1 - Open the Viasat browserthis test won’t work on other browsers;
2 - Go to this website: Viasat Speed Check | Home
3 - Log in using your My Viasat account
4 - Run the test
5 - Download the results (or take a screenshot)
6 - Send me the results in a direct message

Hi, Anderson. Yes it only happens on our desktop.
We don’t use other browsers so I don’t know.
No, we don’t have a VPN

I have a screen shot of our modem speed. How do I get it to you

I figured it out!

1 Like

Hi, @msadkins1998,

Could you check if the issue happens with another browser? You could try with Firefox or Chrome

The speeds look great.

Also, did you notice if that’s happening for every single website?

When that error message appears again, please take a screenshot and send us

I just tried Chrome and it didn’t happen. It’s sporadic and doesn’t happen all the time. I will screenshot it and send it to you the next time.

Thank you for your response.


1 Like

Hello, We have noticed that our guest WiFi has been showing up as unsecured. We recently had guest that have never been here before and they were able to hook up to our wifi without being prompted to enter a password. I checked our settings and was unable to find a setting issue so I called technical support. They said to reboot the modem. We did but the issue still remains. Is there something we are missing?
Thank you

Hi, @msadkins1998,

I’m verifying that. Once I have more information I let you know.

Hi, @msadkins1998,

Please try the following steps:

1 - Go to the Wi-Fi settings page:

2 - Click on “Wi-Fi Settings”

3 - You should see the following on the page, where you can change the settings:

Let me know if that works.

I am familiar with these screens and settings. I looked at them again. Changed the access to “No” and the guest wifis disappeared from the WiFi list on my phone as expected. I changed grant access back to yes and the guest WiFi reappeared on my phone. I was able to connect without entering a password. I changed the password and was still able to connect to the guest WiFi without entering a password. I think I left it with guest access on “No”? Just so people can’t just sign on and use our data. Thank you

Hi, @msadkins1998,

I see your point. Let me check that again.