Weak security warning on Apple Wifi

The root cause of the warning in your apple device or laptop Wifi settings

image

is explained in this Apple support article: Recommended settings for Wi-Fi routers and access points - Apple Support.

If you experience this using a Viasat Wifi router, the solution depends on the type of modem you have. See Which Type of Viasat Modem Do I Have?

If you have an SB2 or SB2+ modem, you’ll need to login to your Viasat router, click the “Wi-Fi Settings” link on the top of the page and set your Security Mode to “WPA2 Personal”:

If you have a Viasat Wifi Gateway Modem, you will only see this error if you have not yet been upgraded to version 4.2, which was still being rolled out across the network as of November, 2022. You can look for your version by logging into your router user interface and scrolling down to the “Identification” section.

Here’s an example of an older version of the Viasat Wifi Gateway Modem software:

Reply to this post (or send a direct message to a moderator) if you would like to request an upgrade for your modem in order to remove this warning.

My modem currently runs the 3.7.9.14.0, is there an update to this version? I want to be able to use WPA3 for Wi-Fi security.

Hi @Leke_Arulogun,

Thank you for reply! I will reach out to the appropriate team to double check if there is a version update for your modem and we will get back to you with an update when we hear back from them.

Thank you,
Cat

Any word back about the modem software update??

Hi @Leke_Arulogun,

Can you please respond to my direct message with your account number? Once you do that, I will be able to further investigate your question.

Thank you,
Cat

Sorry for the slow reply, we heard back from our team of modem experts:

“There is a new software version (SPOCK_4.2.0.5.12) that fixes the ‘weak security’ label that is seen on Wi-Fi connections (especially on iOS) with the 3.7.9.x release, however it doesn’t support WPA3. All Spock modems (AKA Viasat Wi-Fi Gateways) will receive this new 4.2.0.5.12 update in the next couple of months, but if a customer wishes to get it earlier, we can push the update to their modem upon their request.”

@Leke_Arulogun we have pushed the latest update to your modem.

My modem currently runs spock3.7.9.14.0 - I cannot connect to my primary devices due to weak security reading - can you please help.

Hello- How can I get the latest update pushed to my modem? Thank you

Hi @greenhousehouse, we will request the latest software version to be pushed to your modem. I will let you know once this is complete (hopefully later today).

Thanks,

Nacho

Hi @greenhousehouse, we pushed a software update to your modem, it should now be using SPOCK_4.2.0.5.12 - can you please check if this helped with the issues you were experiencing when connecting your devices?

Thanks.

Hi Nacho- it fixed the weak security issue but now am getting a no internet connection message. I have tried all of the restart/reboot combinations that I can imagine and no luck getting my device to connect successfully. I am also trying to connect a smart lighting bridge via ethernet and having trouble with that as well. Please help!

Hi @greenhousehouse, are you getting this “no internet connection” message in a specific device? Or in all of them? Do you have absolutely no connectivity when seeing this error?

Thanks,

Nacho

As far as I can tell it is with all devices- it starts out looking okay- but then when I try to actually use the connection the message pops up. From my cellular connection when I go to the Viasat app- it says everything is fine with my system and the network- but it isn’t working for me- the apple devices tell me to either restart the modem or contact my ISP?

Hi @greenhousehouse ,

we are very sorry for the delay in getting back to you on this. I will create a new forum post so we can better track your issue.

New post: No connectivity apple devices

Thanks,
Leonardo

I tried every possible fix out there untill i fixed it by turning on the private Wi-Fi address option for the Wi-Fi network.

1 Like

Hi, @john_alex,

That’s a very good solution you found, thank you for posting here.