Viasat Stream Problems

I have used the Viasat Stream hub successfully in the past, but for the past 3-4 weeks have had no luck–rebooting only goes so far and I’ve had to do that probably a dozen times with the same result. Standard tech support is unable to assist so I am referred to the Stream tech support, but apparently that group never works! I have called (855-812-6712) throughout the day yesterday and today and get the same message–I am calling outside normal business hours–then the line hangs up. how do I resolve this issue if there is no actual tech support?

Hi @Markalex0711,

Thanks for posting. We can take a look at your account and escalate the issue to another team if needed.

In the meantime, could you please provide more details about your issue with Viasat Stream?



Hi Nacho, history on the stream usage. Approx 2 months ago I began having problems with the Stream Hub. First notification was a number of emails telling me the Hub was not functioning properly. I continued to watch the issue and apparently the problem continued. After some discussion with tech support, they determined I needed a new hub. A new hub was sent, and I replaced the ‘defective’ hub. Since installing the new hub, I have had intermittent access at best, and in the past two weeks I have had no access at all through the hub. By access I mean streaming on Disney+ while not utilizing any of my regular data capacity. I know there has been no access due to my account resetting on the 8th and my access to My Viasat indicates no use on the hub, as well as the current message pulled today:

Finally, I know what I typically use for work during the day, and the days that we stream Disney+ lately I can see where the usage goes up considerably. I do not regularly use VPN, and when I do it is for a short period of time only then closed, and haven’t used a vpn for at least the past two weeks, and to my knowledge I do not have any wifi extenders.

I would question whether or not the new hub was ever sync’d (assuming it needs to be tied in some way) to the modem, but it did seem to work for a short time.

Thank you for your response

Hi, @Markalex0711,

Could you test the equipment again when you have a chance? The team made some adjustments and it should be working now.

Thanks. I just checked and still not working–according to the app. The hub itself is blinking white–I powered it off and reconnected with no change. It even looks like it’s now costing me to use!! Have not used VPN or extenders today.

Hi, @Markalex0711,

Sometimes it can take some time for that presentation to be fully in sync with the real hub status.

Let’s try the following: please stream some Disney+ and give it a couple of hours, then all should normalize.

@Markalex0711, just a note: I’ll double-check about it, but that number doesn’t seem to be a valid Viasat number.

So, whenever you need support with Viasat Stream you can send us a message here in the forum.

Thanks. I’ll look this afternoon. As far as the number shown, that’s what was provided to me by tech support as the Stream Hub specialty team.