Speed Test is not 25mps

Why does my speed test show 2.7 mps when it should be 25 mps? Also the speed test say I don’t have a viasat wifi , but I do.

Hi @SonnyG,

I’m sorry to hear about this bad experience.

I just ran a speed test from your modem and I see good results:

I know this doesn’t represent what you’ve told us, so I need you to do the following:

1 - Open the Viasat browser this test won’t work on other browsers;
2 - Go to this website: Viasat Speed Check | Home
3 - Log in using your My Viasat account
4 - Run the test (wait for both tests - modem and device - to complete)

For a full tutorial, you can see this article: How to run a complete speed diagnosis?.

Please let us know once you’ve run a few of these tests!

Also, do you experience bad speeds all day long or at specific moments of the day (e.g. in the evenings)?

Thank you,
Avner

Hi @SonnyG,

I see that our app couldn’t detect your modem.

You confirmed that you’re using Viasat Wi-Fi, could you double-check that?

Also, are you using any VPN?

Thank you,
Avner

How do I double check to see if it is viasat modem Wi-Fi? I turned VPN off Norton

You can click on the Wi-Fi icon on the bottom right corner and see if the connection is Viasat:
image

If you were using a VPN when you first ran the test, please try again, we’ll be able to connect to your modem and see the actual speeds you are receiving.

Thank you,
Avner

It seems like an instability in the service that runs the modem test
If you could keep trying a few more times until we get a result from your modem that would be ideal.

But from what I can notice, just from disabling the VPN your download speeds have increased significantly, maybe that was the bottleneck.

If possible keep running those tests so we can keep checking your network behavior.

Thank you,
Avner