Really slow speeds

Hi @pgrossjr47

I’ve disabled bridge mode on your modem.

You might notice that the internet drops for a bit (it takes about 20 minutes for the modem to come back from applying this setting).

Can you try accessing viasatmodem.com again, in about 30min from now?

Setting the modem to “Bridge mode” means disabling its inbuilt Wi-Fi router.
When using an external router, you can also set the modem to “Router mode”.

Relevant links –

  1. How to access the modem interface
  2. How do I change Wi-Fi settings on Surfbeam 2+ modem?