MyViasat app isn't working. Just get blank screen

Today, our MyViasat won’t load on the PC’s, the iPads, or mobile apps. We see the Viasat logo, then the screen goes white and nothing happens. Tried powering down the modem - no help. We can’t see our usage, or other functions. Suggestions?

Hi @ramesess ,

Is this only happening on MyViasat? Did you notice any change overnight while accessing other apps/websites as well?

Your modem speeds are good as of this moment, so it could have been a random occurrence of MyViasat not loading properly.

But I can also see that your modem is experiencing some quick timeouts between my speed tests – did you happen to do a test right as the MyViasat app was malfunctioning, to check if the speeds had slowed down?

By the way, I see that your modem was momentarily offline for 15 minutes at 12:30 AM GMT (that would have been 7:30 PM on November 16 for you), and then for a short couple of minutes at 12:45 AM GMT (7:45 PM).

Did you notice this loss of connection? This might be related to the malfunctioning of MyViasat.

Thanks for the reply. MyViasat is still down this morning. The 15 min downtime is when I powered the modem off to see if it would reset the app - no help. The periodic stoppages are something that’s been happening for some time now. Apps will suddenly tell you to connect to the internet out of the blue. The modem is still a solid blue light, but the connection is lost briefly. I don’t do speed tests very often, and haven’t for a couple of weeks, so that wasn’t a factor.

I tried MyViasat on both Firefox, Safari, and Edge browsers - blank screen. Safari reported: “Safari can’t open the page because the server can’t be found.”

I deleted the app on my iPad and reloaded - no help.

Could this be related to my earlier issue of my modem directing me to Canada websites? Paramount+ was going to /ca whenever I tried to load the app. I still see a lot of Canadian ads and news in my feeds. Just a thought.

I just tried to use the MyViasat app on my phone through the ATT connection, instead of using the modem, and the phone can’t open the app either.

Hi again @ramesess ,

Thank you for the info. I’ve escalated your issue to the MyViasat team, due to this previous problem with the Canadian redirection.

We’re still investigating that weird Canada bug, but hopefully, the team will have an update soon on the MyViasat app’s unresponsiveness.

In the meanwhile, would you like me to send you a private message with your remaining data or other functions from your account? Just so you aren’t kept in the dark while the team fixes this issue.

At approximately 1:30 PM EST (Indiana) on Friday access to MyViasat apps on all devices returned. As of now 1:30 AM Saturday morning it is still working.

Dennis Sheron

1 Like

Got it, @ramesess. Thanks for the feedback.

Hi @ramesess ,

We checked back with the MyViasat team and they told us a bug fix was being deployed right around the times when you were trying to connect to the website – that’s why it was totally down. They finished that on Friday, so that lines up with your reply. :wink: