iPhone reports "No Internet Connection" for Viasat Wifi

Sometimes I notice that my iPhone (iPhone 12 Pro with version 15.6.1 iOS) Wifi settings shows “No Internet Connection” when I am connected to Wifi connected to Viasat:

But at the same time the Wifi on my laptop shows it is connected with no error:
image

Also, it doesn’t seem to effect my use of the Wifi from that same phone – at least not most of the time. The error often goes away by itself after a minute or so. Has anyone else seen this? Anything I can or should do about it?

We are looking into this issue and will report back when we have learned something. Thanks for reporting it!

Yeah they have been looking “into” this issue for about a year now. I have called them numerous times and they always give me the run around. Like try unplugging and reboot your modem. It’s crap. My phone get no connection all the time on and off. It actually gives me a huge lag in the beginning of a web page. I want a new modem but you think they will help??? Heck no. If I could use someone else I would. Being in remote area and they won’t send anyone out at all!! It’s crap!! Im on all the plans for service and additional help with No of ale. Maybe the wind will blow my dish off the roof or something

@NDF3210 You are right that we haven’t been able to root cause this. Question: is the problem just that it says “No Internet Connection”? Meaning, are you still able to use the Internet even when you see this error?

"It actually gives me a huge lag in the beginning of a web page. "
Also, Are you able to characterize that at all? Meaning, which web page? Does it happen all the time? Anything you can provide to help us reproduce it? It might be good to create a separate forum thread for this since it is likely to be independent of the “No Internet Connection” on iOS issue.

Yes I can still get internet but there is always a huge lag in the beginning. Doesn’t matter which site im going to. It really gets frustrating. I even released and renewed my IP address. Still the same issue. Done everything I think I can do. Which is why I would just like to try a new modem. Mine is about 2 years old now. You can mail it to me I’ll figure it out.

I’ve givin up. Really thinking about switching

It’s is the no internet connection on IOS. Same as above. Computer work fine when plugged in. My phone is IPhone 14 Pro Max. But it does it on all iPhones

To be clear, on your iPhone 14, when it says “no internet connection”, are you still able to use the Internet. For instance, can you run a speedtest and send the results when it says “No Internet Connection”. Or, on the other hand, are you actually unable to reach the Internet at this time. Thanks for the clarification.

After pulling my hair and searching everywhere , I solved it by forgetting the Wi-Fi network and join it again.

2 Likes

Hi, @john_alex,

Thanks for the recommendation!

@NDF3210, not sure if you still have that issue, but if so you could try @john_alex’s fix (here or here)

As described in this topic, the issue has also something to do with an older software version of the modem, but I checked yours and it was already upgraded to the latest version

@john_alex whoa this is big. After you did this, the problem went away and has not returned?

After pulling my hair and searching everywhere , I solved it by enabling and then disable the airplane mode option.

1 Like

Hi @john_alex, thanks for that info.

Would you have to do this each time you connect to your Viasat Wi-Fi? For example, if you leave your home and later come back, would you need to apply either of those workarounds (forgetting Wi-Fi network OR enabling/disabling airplane mode) again in order to connect?

I finally figured it out after a lot of frustration and searching everywhere, I just had to forget the Wi-Fi network and then reconnect to it.

Here is what happening here. There’s no internet connection on my iOS device. This issue persists with all iPhones. However, my computer works fine when it’s connected. I’m currently using an iPhone 14 Pro Max, but this problem occurs with every iPhone model I’ve tried.