Having some issues with the speed

hi we have been having issues with the internet speeds for the past week and a half . here is the speed check test results from this evening . i have a router for the wifi signal but use network cables for my pc and game console. we have had this service since 2016 and this is the first time we have had any issues.

Hi @MCCOMAS122,

Thanks for posting. I’ll take a look at your account and report back here.

Thanks,

Nacho

Hi @MCCOMAS122,

I noticed that you were out of priority data, so I added 30 GBs of additional priority data (free-of-charge) to your account. Then I ran a speed test from your modem, and the speeds seem to have improved:

Could you please confirm that this improved the experience?

Thanks,

Nacho


it helped .thanks like i said we haven’t had any issues till now . thanks again

why was i charged for the extra data ? when it was supposed to be free of charge .

Hi, @MCCOMAS122,

You probably received an automatic email about the “Buy More” data, but don’t worry, you will see in your billing a credit for that extra data.

Thanks,

Anderson

1 Like

@MCCOMAS122,

We found out that your antenna is mispointed. I will request a truck roll and let you know.

The field team will contact you to give you more details.

I will send a DM so you can confirm the best telephone number to reach you.

Thanks,

Anderson

Hi @MCCOMAS122 ,

I just wanted to confirm if you were able to talk to the field team to schedule the tech visit. According to our system, a voice message was left for you at the phone number you’ve informed.

Thanks,
Leonardo

we talked to him and he said he would be here by 3 friday evening and would call when he started this way , we haven’t heard from him since . waited all day for him to call he never called back.

Hi @MCCOMAS122,

Sorry about that, I’ll check with our field services team and make sure we reschedule as soon as possible.

Thanks,

Nacho

he called and will be here tomorrow .

Hi @MCCOMAS122 thank you for the update! Please let us know if you are still experiencing issues after the tech visit.

Hello @MCCOMAS122 ,

Just wanted to check if the tech visit happened and things are working fine with your connection?

Thanks,
Gregório

he adjusted the dish and its working better , thanks

1 Like

Hi @MCCOMAS122,

Thank you for the update and happy to hear that your experience has improved. Please don’t hesitate to reach out if you start having issues again.

Best,
Cat

I would like to state that from day one I have not been able to watch anything or use any data but y’all said I use my 100 GB of data and I’ve never watched nothing this satellite does not work I have it completely disconnected I’m going back to my old company if you call them and tell them something’s wrong they’re out here to check it I’ve called y’all I don’t know how many times you want to charge me to fix your equipment so I haven’t been hooked up to y’all since the last time I called your modem is in a closet it’s not even hooked up your satellite is disconnected I never could tell if the speeds were bad cuz I’ve never got to watch any program or TV show nothing y’all can come get your equipment this is the worst I have ever seen out of any company I would not recommend you all to my worst enemy do what you got to do to me charge me anything you want to charge me you’re not getting no money I live close to downtown all the people getting off work come by my house every day I’m going to put a sign in the front yard telling people don’t even let y
'all talk to them you’re the worst company I’ve ever had to deal with in my whole lifePreformatted text

Hi @James_Zapata,

We are sorry about this experience. Our team of engineers that moderates this forum is happy to help with technical issues. I understand that you might have already decided to disconnect your Viasat service, but in case you haven’t (and are willing to reconnect your equipment) I went ahead and created this new thread for us to troubleshoot the problems you are experiencing: I have not been able to watch anything