Disable DirecTV Wireless Connectivity

I enabled DirecTV to access an on-demand movie. Noe I can’t find a way to DISable the wireless connection to Viasat.

DirecTV support says to reset network connections, but that doesn’t offer an obvious way to disconnect wireless.

I could change the password on the Viasat router, but that means I then have to update a zillion other wireless devices that I DO want to have connected.

Thank you for any ideas.


Hi @Donwallbaum1 ,

Thanks for your contact. Could you provide some more details on how your DirecTV is connected to your Viasat internet? From my understanding, this connection was made via Wi-FI, is this correct? If so, resetting the network settings on the DirecTV device should make it unable to connect. If possible, turn your DirecTV off and unplug it for more than 20 seconds, turn it on again, and perform the reset on the network settings. If that does not work, please let us know and we can try to verify if something can be done on our side.

However, I’d still recommend checking with DirecTV support to see if there’s a solution that does not include resetting your router’s password, since they are the ones that can provide you with specialized support on that.


Hi Leonardo,

Thank you for the rapid response, and this is admittedly a DirecTV issue, but DT support tends to be most helpful when you want to add a feature, and not so helpful when you want to remove one.

You are correct, DirecTV was connected to Viasat via wifi - an error in hindsight, I should have just cabled the connection.

What is lacking is a simple “disable internet connection” button. I will try the power down/reset approach -I have not tried first powering down, so maybe that is the key.

For now, I may have gotten a working solution by selecting a GUEST network that has a password that I had not told DirecTV about, so that GUEST PW is unknown.

Again, this is not Viasat’s problem, but thought I would try youall, since queries to DT have not been helpful.

I appreciate your time, thank you.


Hi @Donwallbaum1,

Another workaround you could try using is changing the parental control settings on your modem to block internet access on your DirectTV device. This article explains how to do it: How to use parental control settings on my Viasat modem?

Oooohhhhh…. Clever!

I will look into that, thank you!


Hello, @Donwallbaum1,

Did that workaround that Nacho mentioned solve the issue?

Let us know if there is anything else we can help with.



Have not tried the workaround yet, will let you know.

Thank you!