Continuing issues

Have complained before on upload speed. Told was monitored and “all fine…”. Now like many others I see on the posts Disney plus not working at all - 5 days now- reporting “error code 42” “slow internet connection speeds” with the added streaming device???”
Speed on download is less than 15mps and upload still terrible at 0.4mps. Very poor service.

Hi @Nk.A

Regarding the Disney+ issue

Are you still experiencing this problem?

Regarding the upload speeds

The situation remains as we explained on the previous topic:

As a sidenote, your account was previously one of a select few with which our Speedcheck tool had been having issues and couldn’t save your speed test results.

Could you try running a few complete ones for us when you have time? We’ve recently started to roll out the fix for this issue, so in theory any full Speedcheck you run (device + modem test) should show up for us. :slight_smile:

We’d made some network changes to your account on that previous post, so it’s worth checking if they have increased the speeds from the first time you posted. Please keep in mind that your Viasat plan offers “Download speeds of up to 75Mbps and upload speeds of up to 3Mbps”, but you may see a lot of fluctuation in between those numbers.

Please, follow the guide below and let us know if you experience any issues while testing:

  • You can download the Viasat Browser here: https://browser.viasat.com/.
  • After you install the browser, you need to be logged in on speedcheck.viasat.com.
    • To do that, click “Login” in the upper right corner of the menu, as indicated in the picture below.
    • The credentials for this login are the same as the ones you use for MyViasat.

image


When you run the tests from the Viasat browser, we can see “Speed from your device” and most importantly “Speed from your modem”, which is greatly useful to identify discrepancies in the speeds, such as in this example below:

:exclamation: The Modem Speed Test is currently not compatible with iPhone/iOS devices. If you don’t have an Android mobile device, please run the test on a computer.

Thank you!

Thank you for the response. Speed was good this morning early and still ok now. All apps working on my one TV except Disney+. It still says “Error Code 42”. The streaming device I have unplugged 2 x to reset. But no change. The streaming drive is blinking white. Always has done that.
TV is Ethernet cabled directly to the mesh dual band WiFi which is Ethernet cabled to the Viasat modem. Mesh system running full speed on Viasat speed test.

Hi @Nk.A

According to Disney’s support page, the Error 42 is likely an internet or network connection issue.

Troubleshooting

To resolve this Disney+ error (and related errors):

  1. Make sure you are on a supported device or accessing DisneyPlus.com on a computer with a supported configuration
  2. Check your internet connection¹ and Wi-Fi signal
  3. For more information, see Troubleshooting playback and streaming issues
  4. Power cycle (power down and restart) your router and modem
  5. Relaunch the Disney+ app or refresh the site and try playing the video again in a few minutes

¹If you recently experienced a service outage with your internet service, it is strongly recommended to power cycle your modem and router (and Mesh, in this case).


If the troubleshooting steps provided by Disney’s support page don’t work, they also recommend getting in touch with their agents directly for further assistance.

You can do that using this link: https://help.disneyplus.com/contact-us

In the meantime, I’ll escalate your issue to the Stream Hub team to check if your equipment is working as intended.

Hi again @Nk.A

I heard back from the Stream Hub team, and your Hub is working normally, no hardware or software issues.

Are you still seeing that error?

Sorry, am traveling at the moment. Will test again when returning.

1 Like

Hi @Nk.A

No problem! We’ll keep this topic On Hold until you’re able to test again :wink:

Safe travels!