Cannot access link to add to high speed data

I ran out of high speed data and received an email from Viasat indicating i could click on one of the options to add more data. However when I click on any of the options I get the message
The connection for this site is not secure
pages-email.info.viasat.com uses an unsupported protocol.
ERR_SSL_VERSION_OR_CIPHER_MISMATCH

I have tried this using different browsers and from both an android and iphone and get the same results. I have gone through the google troubleshooting for this error message but can’t resolve it.
Can someone help with this.

Hi @tinarogers1215

Do you currently have the MyViasat app on your phone?

You can buy high-speed data boosts inside the app, or with Customer Care for Residential Customers (855-463-9333).

I was using the link from the email I received and expected that to work. It didnt as i was getting an unsupported protocol error. I know I can do it through calling, which I did, but wondering why i received the error message and why it can’t be accessed that way. I do not have the app installed.

Thanks for the feedback, @tinarogers1215.

We escalated to the responsible team and they are investigating that. As soon as we have an update we’ll let you know.

Hi, @tinarogers1215,

Can you send us a screenshot of the email in the DM we sent previously?

Hi, @tinarogers1215,

The team identified the issue and is working to fix that website soon.

Sorry for the inconvenience, and thanks for reporting the issue.