Buffering non stop!

Streaming Uzzu for MLB buffers non stop and then plays for maybe 3-10 seconds. Other streaming services also uncomfortably slow. Have tried rebooting chromecast, viasat modem and clearing devices. This has now worked well since we started our account.

1 Like

Hi, @abj10y,

Thanks for your message (and sorry for the delay in replying)

I need to ask you some questions:

  • Does that happen only during the night?
  • Did you try adjusting the video quality?
  • Are other apps/devices affected, or is the issue mainly related to streaming apps?

I did some tests now, and the speeds on your modem were good:

I have the results of 2 tests you did:

It’s the peak busy hours around 9 PM, and around that time some speed fluctuation is expected. There could also be some problem with your router, but to confirm that we need to have more data (test results).

It happens anytime of day and is worse on live streams. Video quality can not be changed on uzzo that I am aware of. The only devices being used during streaming is chromecast and a cell phone.

Hi @abj10y ,

Could you kindly run an advanced speedcheck? The advanced speedcheck shows your device speeds as well as your modem’s, which helps in our analysis.

Please also run a test on fast.com and post the detailed results.

Thanks,
Leonardo

16

Mbps

Latency

Unloaded
601 ms

Loaded
1.4 s

Upload
Speed
2.9 Mbps

Hi @abj10y ,

Thank you very much for those results. Did you also run the advanced speedcheck at speedcheck.viasat.com as well?

Thanks,
Leonardo

Speed From Your Device

DOWNLOAD## 16.48Mpbs

UPLOAD## 4.72Mbps

  • ISP:
    ViaSat,Inc.

Honestly this is the worse internet experience I have ever seen.

Hi @abj10y,

You mentioned Chromecast, are you streaming MLB games on Uzzu using your TV? Do you also get the same kind of buffering when streaming on your phone or laptop?

Thanks,

Nacho

Same results on all.

Hi @abj10y,

Have you experienced similar issues with other streaming platforms? Or just with Uzzu?

I ask because I’m wondering if the issue is on Uzzu’s side. I hadn’t heard of it, so I did some Googling and came across these reviews that claim buffering - Uzzu Reviews - 35 Reviews of Uzzu.tv | Sitejabber :thinking:

It buffers on several different platforms.

Hi @abj10y ,

I see that your tests were all run during the night.

Your earlier results don’t seem to be too divergent from your plan (about 18-21 Mbps), but I see sometimes a drop to 14 Mbps and even 11 Mbps on your device speed – is it close to the modem?

Like my colleagues say, your modem shows good speeds during the day, up to 3x your plan of 25 Mbps – but again, our tests were run during the day.

When you have the time, could you please run another couple of tests from the Viasat Browser, but during the morning or afternoon, so we can eliminate other possibilites?

Thank you!

41

Mbps
Latency
Unloaded
579 ms

Loaded
1.0 s
Upload
Speed
6.5

Hi @abj10y ,

That test you replied with and the other one you ran during the morning both show good speeds from your modem and the device you were using, keeping in mind the fluctuation.

In theory, you should be able to watch high-definition videos with no problem, so let’s test something else:

Can you also run a few speed checks on fast.com for us? It’s a tool developed by Netflix to specifically test your video streaming speeds (not your internet speeds in general), so we can pinpoint exactly what speed you’re getting when trying to watch videos.

As it has no relation to Viasat, I won’t be able to see your fast.com results, so please screenshot them for us here if you can. :wink:

Thanks,

Nathalia

1.5

Mbps

Latency

Unloaded
404 ms

Loaded
1.5 s

Upload
Speed
11 Kbps

Hi @abj10y ,

Thanks for running the fast.com test.

There’s a considerable discrepancy between your video streaming speeds and your modem/device speeds, judging by the results you sent us.

Do you currently use a VPN on your devices?

Could you try connecting your device directly to the modem with an Ethernet cable, and testing to see if those platforms are still buffering?

Hi again @abj10y ,

I asked our video streaming experts to see if there’s any hidden configuration that could be causing your issue.

As a last favor, could you run a fast.com test again, and right when it finishes, run another speedcheck.viasat.com using the Viasat Browser?

This way, we can eliminate factors like the distance between the devices.

Thank you,

Nathalia

1.5Speed From Your Device
DOWNLOAD
35.15Mpbs
UPLOAD
5.02Mbps
ISP:
AT&T Services, Inc.

Mbps

Latency

Unloaded
170 ms

Loaded
347 ms

Upload
Speed
0 Mbps

24

Mbps

Latency

Unloaded
608 ms

Loaded
1.2 s

Upload
Speed
4.4 Mbps

Client Crockett, US Viasat
Server(s) Aurora, US | Chicago, US | New York, US